Warning: Error while sending QUERY packet. PID=8446 in /home/wwwroot/coco/domain/cnlamp/web/wp-includes/wp-db.php on line 1924 修复Ubuntu 14.04中Chromium的Adobe Flash Player的问题 | LAMP新闻|技巧|经验|资讯站
现在的位置: 首页Linux>正文
修复Ubuntu 14.04中Chromium的Adobe Flash Player的问题
发表于3年前 Linux 暂无评论
安装Ubuntu 14.04之后,先要做的几件事情中其中一项是安装Adobe Flash Player。一般来说,如果安装了Ubuntu Restricted Extras,Flash Player应该可以工作而且你应该能够在网上观看在线视频,比如You Tube等网站上。

其实这不是因为Chromium是在Ubuntu 14.04上使用才出现的问题。当你用其他的网页浏览器比如火狐、Chrome时,你可以轻松地播放You Tube等网站视频,但在Chromium中你将会看到Adobe Flash player缺失插件的通知:

Adobe Flash Player is required to display some elements on this page. Install plug-in..

只有在Chromium中出现flash player问题的原因:

只有在Chromium中发生这个问题的原因是,之前Chromium使用Netscape Plugin API构架来支持Flash,从Ubuntu 14.04开始,Chromium将会停止使用Netscape Plugin API。因此,我们才遇到Chromium的Adobe Flash Player的问题。

那么,为什么这个问题没有发生在其他浏览器上?答案是,因为它们使用 Flash Player 11.2。

修复Chromium上Adobe Flash Player的问题:

修复这个问题,我们应该使用Pepper Flash Player,一个来自Google更安全更稳定的版本的Flash Player。在Ubuntu 14.04的源里有Adobe Flash Player Pepper 安装器。这个安装器会下载Google Chrome,提取出Pepper Flash Player然后设置给Chromium使用。

要在Ubuntu 14.04安装Pepper Flash Player,打开一个终端,使用下面的命令:

sudo apt-get install pepperflashplugin-nonfree
sudo update-pepperflashplugin-nonfree --install

之后重启Chromium。不用重启系统。

给我留言

留言无头像?


×
腾讯微博